Technology Refresh – Orientation Briefing for TFMS Users
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1 Introduction

During FY 2010, TFMS hardware at 84 Air Traffic Control facilities will be replaced with new workstations, monitors, printers, servers and support equipment.   The current Red Hat Enterprise Linux (RHEL) 3.8 operating system will be upgraded to RHEL 5.4.

Operational users of applications such as the Traffic Situation Display (TSD), National Traffic Management Log (NTML), Flight Schedule Monitor (FSM), Enhanced Status Information System (ESIS), and Route Manager will notice only slight changes to displays with the Technology Refreshed equipment.  
The applications can still be started, stopped, and utilized as they were previously, and the familiar short cut or quick keys work as well.
The new equipment replaces obsolescing models, and more support and maintenance functions are automated or performed from the TFMS Consolidated Service Desk at the William J Hughes Technical Center in Atlantic City, NJ.  With the increased automation and centralized support, new security measures are being adopted.  For example, the use of removable media such as CDs, DVDs, or thumb drives will no longer be supported on the TFMS equipment.  
The upgrade to RHEL 5.4 includes a new version of the GNOME desktop and the Mozilla Firefox browser.  This upgrade will present slight differences in window appearances, new icons on the GNOME panel, and changes to the menus.  
The network name has changed from the Enhanced Traffic Management System (ETMS) to the Traffic Flow Management System (TFMS), so most references to ETMS have been changed to TFMS. 
This briefing is an introduction to some features of the new workstations, servers and printers, as well as desktop and browser differences that you can expect to encounter when you start to use the new equipment.
2 Hardware Changes
2.1 New Workstations and Servers
A major part of the Technology Refresh revolves around the distribution of new workstations and servers that reflect the latest technology available.  The new monitors provide higher resolution on a 24 inch LCD display.  (At some facilities, where space is limited, the existing monitors will be retained.)
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Figure 2‑1. TFMS Workstation
	[image: image2.wmf]Please Note

	To enhance system security, the new equipment does not support removable media such as CDs, DVDs, or thumb drives.  A new FTP procedure for downloading files has been developed.  
Please contact your local System Administrator or call the TFMS Consolidated Service Desk at 1-609-485-9601 for help.


2.2 New Printers
Existing printers will be replaced with the HP OfficeJet Pro 8000 model.
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Figure 2‑2. Standard Printer

The new printers feature a 250-sheet input and a 150-sheet output tray, and available 2-sided printing.
To enable 2-sided printing for a specific print job, you can choose “two-sided” printing from the "Page Setup” tab in the print property options. 
To set or change default printers, please call the TFMS Consolidated Service Desk at 1-609-485-9601 for help. 
	[image: image4.wmf]Please Note

	To successfully print your NTML log using the new printers, your NTML System Administrator may have to edit the PRINT_MODE option found in the NTML configuration file to print as “postscript”.  

TFMS Consolidated Service Desk personnel can also help with editing your NTML configuration file.


3 RHEL 5.4 Operating System Changes 
Red Hat Enterprise Linux 5.4 is the newest generation of the Red Hat Linux operating system.  The accompanying GNOME desktop has also been upgraded.  This section will explore some of the differences between RHEL 3.8 (the current version) and the new RHEL 5.4. 
3.1 Display Changes

Figure 3-1 shows the default RHEL 5.4 desktop display.  The default background can be changed by right clicking anywhere on the screen and then selecting “Change Desktop Background”.
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Figure 3-1. Default TFMS Workstation Desktop

There is only one choice for screensaver – a blank screen.  However, you can adjust the time limit for screensaver activation using the “System” menu:  click on System->Preferences
->Screensaver->Activate Screensaver When Computer is Idle, then use the scrollbar to adjust the time.
Figure 3-2 zooms in on the new icons displayed on the default desktop for the Computer, Home Folder, and Trash.
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Figure 3-2. RHEL 5.4 Default Desktop Icons

The default user’s Home folder file manager configuration will only show the contents of your home folder.  To switch to the Browser view, in which you can see the entire file directory structure (as you could in RHEL 3.8), see your local System Administrator.

Figure 3-3 shows some slight differences in the window displays on the new GNOME desktop. 
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Figure 3-3. Window Differences
You can still “roll up” your windows by double clicking anywhere on the title bar of an open window.  To restore the window, just double click again on the title bar.
3.2 GNOME Panel Bar Changes

Figure 3-4 shows a comparison of the old and new GNOME panel bars.
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Figure 3-4. RHEL 3.8 (top) and RHEL 5.4 (bottom)
The familiar “Red Hat” menu icon used in RHEL 3.8 to access the user applications has been changed to the GNOME “Foot” icon.

The menu that contains links to the TFM suite of applications has changed from “ETMS” to “TFMS”.  
The “Applications”, “Places”, “System”, “TFMS” and the browser launcher menu icons have been locked on the panel bar and cannot be moved, hidden, or deleted.
All other icons, including the workspace switcher, can be moved to a different location on the panel:  right click on the icon, uncheck “Lock to Panel”, drag the icon to the new location, and drop it there.  You can also lock the icon in the new location:  right click on the icon, check Lock to Panel”. 
The default workspace switcher on the panel bar is set to show four workspaces without workspace names.  If you right click on it, you can access the preferences.  From the preferences you may elect to put names on the workspaces, to rearrange them in stacked rows, or to add more workspaces.   
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Figure 3-5. RHEL 5.4 Hide Buttons

The new GNOME panel can be hidden just as in the old system.  The hide buttons are located at the far-left and the far-right corners of the panel bar.  To enable and configure the hide buttons:  right click on any blank space on the panel, select Properties->General->Show hide buttons
->Arrows on hide buttons.  The hide buttons will hide or unhide the panel when clicked.

By design, the GNOME panel cannot be resized, moved, or deleted.  But you can create a new panel bar in the location of your choice and add any desired menu icons, launchers, notification areas, and workspaces.  Just right click on the panel, and select “New Panel” to access all of the panel properties, including “Orientation”.  The new panel will pop up in the location selected.
Your workstation sound card directs sounds to an onboard speaker.  At the far right side of the GNOME panel, you will find an icon for a speaker.  Click on the icon to open a dialog box from which you can mute or adjust the sound level.  To check the sound level, open up a terminal window and press the backspace key to force a beep. You can continue to adjust the sound level until it reaches the desired level.

More information can be found in the Red Hat Help files accessible from the “System” menu.
3.3 Menu Changes
The options that were formerly available from the “Red Hat” menu icon have been divided into three separate menus:  “Applications”, “Places”, and “System”.  While the menu options have remained essentially the same, they have been reordered and many were renamed to be more descriptive.
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Figure 3-6. RHEL 5.4 Menu Choices on Panel Bar

Figure 3-7 shows the “Applications” menu, which allows you to access the browser and to run installed applications.  
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Figure 3-7. RHEL 5.4 Applications Menu

Figure 3-8 shows the “Places” menu, which provides access to folders and storage resources for the workstation. 
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Figure 3-8. RHEL 5.4 Places Menu
To enhance system security, the “CD/DVD Creator” option in this menu has been disabled.  
Figure 3-9 shows the “System” Menu, which provides access to administrative tasks and GNOME Help, and the ability to log out.
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Figure 3-9. RHEL 5.4 System Menu 

Use the “Log Out etms…” option to save your preferences after you have set the desktop up the way you like it.  When you log back in, your preferences will be saved on that workstation.  
Figure 3-10 shows the “TFMS” menu, which provides access to TFMS tools. 
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Figure 3-10. RHEL 5.4 TFMS Menu

3.4 Firefox Features

As part of the Technology Refresh, the version of Mozilla has changed from SeaMonkey to Firefox.  While SeaMonkey was comprised of a web browser and an HTML editor, Firefox is strictly a web browser, thus many of the menu items are different.  

3.4.1 Opening a Firefox Browser

Previously you could open your browser from three places on the GNOME panel:  the launcher icon, the “ETMS” menu, or the “Red Hat” menu.  With the new system, you can only open a browser from two places on the panel:  the launcher icon or the “Applications” menu. 
The option to open a browser from TSD Help or from a terminal window has not changed.

To open the browser using the launcher:  Click on the “Globe” launcher.   
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Figure 3-11. RHEL 5.4 “Globe” Launcher Icon
To open a browser using the “Applications” menu:  Select Applications->Interne->Firefox Web Browser  
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Figure 3-12. Launching the Firefox Browser

You cannot use the default Globe launcher on the GNOME panel to more than one browser window.  
However, you can add another launcher to the panel bar and use that launcher to open multiple windows.  To add you own launcher: select Applications->Internet->Firefox Web Browser and right click on it.  From the dialog box choose: Add this launcher to panel.  A new Firefox icon will be added to the panel, and you can click on that launcher to open additional windows.
Once you have your Firefox browser open, you can also open additional windows by holding down the CTRL and N keys, or by using the “Applications” menu again.  
3.4.2 Firefox Menu Options

Since Firefox is strictly a browser, the menus no longer include the editor tools that came with SeaMonkey.  In addition, some of the menus and/or their underlying menu options were reordered or renamed to be more descriptive.  

Figure 3-13 shows the SeaMonkey menu bar, which had eight menu options, and below it the Firefox menu bar, which has seven menu options.  Some of the differences between the menus and their options will be detailed on the following pages.
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Figure 3-13. SeaMonkey and Firefox Menu Bars
3.4.2.1  The “File” Menu
Figure 3-14 shows the SeaMonkey and the Firefox “File” menus.  Firefox presents a new menu organization and has renamed some of the options.
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Figure 3-14. The “File” Menus

3.4.2.2   The “Edit” Menu
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Figure 3-15 shows the “Edit” menus.  Some of the “Find” and “Fill In” options no longer exist in Firefox.  
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Figure 3-15. The “Edit” Menus

Figure 3-16 shows the seven different “Preference” screens accessible from the “Edit” menu from which you can choose configuration options.
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Figure 3-16. The “Edit” Menu “Preference” Options  

3.4.2.3 The “View” Menu
Figure 3-17 shows the “View” menus.  The new “View” menu includes the “Toolbar”, “Status Bar” and “Sidebar” options.
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Figure 3-17. The “View” Menus 
3.4.2.4  The “History” Menu

Figure 3-18 shows the “Go” menu on SeaMonkey, which was renamed “History” on Firefox, but has retained the same functionalities.
[image: image49.jpg]Create Folder
Create Launcher.

reate Document No templates |

Open Terminal [ Empty Fie

Clean Up by Name
 Keep Aligned

B easte

Change Desktop Background





[image: image28.png]Edit

View

Bookmarks  Tools

Back  Alt+left Arow
Foward Alt+Right Arrow
Home  Alt+Home

History  CtrleH

 ATCSCC Intranet

Window  Help





Figure 3-18. The “Go” and “History” Menus

3.4.2.5  The “Bookmarks” Menu

Figure 3-19 shows the “Bookmarks” menus.  The “Personal Toolbar Folder” has been renamed “Bookmarks Toolbar” in Firefox, but serves the same function.
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Figure 3-19. The “Bookmarks” Menus 

3.4.2.6  The “Tools” Menu

Figure 3-20 shows the “Tools” menus.  All of the managers have been deleted in the Firefox version of the browser.
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Figure 3-20. The “Tools” Menus
3.4.2.7  The “Help” Menu

Figure 3-21 shows the Help menus.  Firefox provides two “Report” options, but does not have the “About Plug-ins” option.
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Figure 3-21. The “Help” Menus
3.5 Adding and Closing Tabs in a Firefox Window

Firefox has the capability, like SeaMonkey, to open web pages within the same browser by using tabs.  By default the tabs in Firefox will be displayed as shown below.  
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To open multiple tabs within a browser:
1. Click on File on the menu bar.  A drop down menu will open.
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2. Click on New Tab.
3. A new tab will be added.  

If this is the first tab added, it will start the tab toolbar.  Once you add more tabs, you can access each web page or jump between them with a mouse click.  As you add more tabs, they will also be displayed on the Tab toolbar.  
To close a tab, click on the “X” located on the tab.  
You may also use keyboard commands to add a new tab.  To add a new tab, hold down the Ctrl key and press the letter T.  A new tab will be added to the active browser window.  

To close all tabs and the browser, click on the “X” located at the upper right had corner of the Firefox window.
3.6 Right Click Menu Changes
In RHEL 5.4 the menu that appears when you right click on a blank place on the desktop has changed.  
Figure 3-22 shows the differences between the RHEL 3.8 and the RHEL 5.4 response to a right click.
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Figure 3-22. RHEL 3.8 (left) and RHEL 5.4 (right)

You can change your desktop background from this menu, but the “Scripts” and “Disks” options are no longer available.
4 Summary

The Technology Refresh brings a new platform to the facilities, complete with the new workstation, larger monitors with higher resolution, new printers, and an upgrade to RHEL 5.4.

The basic TFMS tools (TSD, NTML, ESIS, FSM) are still accessible from the workstation and with the exception of minor window display differences are unaffected.  These applications will continue to perform as they do in the current system.  
RHEL 5.4 presents a new menu organization with some options renamed to be more descriptive.  The available options will continue to perform as they do in the current system.

The new browser Firefox presents a new launcher icon, new menu organization, and new methods for opening and closing browsers and tabs.  Firefox looks a little different and is strictly a browser; however, it provides essentially the same browser functionality as SeaMonkey did in the previous system.
TFMS Consolidated Service Desk personnel are available 24x7 (609-485-9601) to answer questions and assist with any new equipment. 

Technology Refresh – Orientation Briefing for TFMS Users
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